Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
Posts: 1

Hero 8 Black frozen/stuck during firmware upgrade

[ New ]

I got a new Hero 8 Black today and the first thing it asked me to do on the app is update the firmware. I went ahead and did it but it never got past trying to install the firmware in the camera. I tried downloading it on the computer and putting it on the SD card but the same thing happens. The camera has now bricked up and won't fire up normally, and i can't get a working firmware to install! This is ridiculous. I've stayed away from GoPro since the Hero 3 for this EXACT reason. The first one I buy all these years later does exactly the same thing! Does anyone have a solution to this? I'm told all support is unavailable at weekends!


I have tried formatting the card and downloading again etc, by the way.

Posts: 13,525

Re: Hero 8 Black frozen/stuck during firmware upgrade

[ New ]

What this sounds like you will need to return for a refund, exchange. and you bought at  Contact them and  they can set up what you want.


fw   I try is an older one, update in the camera. that may unbrick it.


Where do not ask me, look for it.

Posts: 11,001

Re: Hero 8 Black frozen/stuck during firmware upgrade

[ New ]

@steadijim, please make sure that a recommended SD card is used. Using SD cards that aren't recommended can cause issues during the firmware update installation.


Try to remove the battery from the camera and insert it back after about ten (10) seconds. The camera should attempt to install the update again as soon as you power it on using the Mode button.

Let me know how it goes.