Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Tourist
Posts: 5

Hero 7 and external mics..... no joy here...

Ok... I bought a Hero 7 Black and the horrible, bulky Promic adapter. 
I updated the fimware on my Hero 7.

I tried to use two mics, a Rode VideoMicro and a cheapie lapel mic, which both work with other devices.

One has a TS plug, one has a TRS plug.
Neither of these worked. There's no audio when the adapter is plugged in.

I contacted support.
I did a manual fimware update. No joy.

Gopro sent me another ProMic adapter, same results.

I got told I needed a TRRS - TRS adapter.

I got told I didn't need a TRRS - TRS adapter.

 

GoPro replaced the camera.
I manually upgraded the firmware.
Still nothing works, with either adapter.

I need the external mic as I use the Gopro on my helmet when flying a microlight.
Currently, I'm out nearly £400 and still can't use this thing. Close to just asking for my money back..

If anyone has ANY knowledge, PLEASE HELP! 

Thanks in advance.....
Paul.

Tourist
Posts: 5

Re: Hero 7 and external mics..... no joy here...

Also, not using quick capture, and camera audio setting is set to Standard Mic.
Adventurer
Posts: 11,264

Re: Hero 7 and external mics..... no joy here...

Adventurer
Posts: 11,264

Re: Hero 7 and external mics..... no joy here...

  SImple as 1, 2, 3,  I demo'd it working what cables   mics pins you actually are using?

a photo is bestto show i do video's Lol

Tourist
Posts: 5

Re: Hero 7 and external mics..... no joy here...

I'm not sure how this helps me, fishycomics, but I'm happy that yours works! Smiley LOL

Tourist
Posts: 5

Re: Hero 7 and external mics..... no joy here...

A Rode VideoMicro and a cheap lapel mic. The Rode is TRS and the lapel mic is TS.

Tourist
Posts: 5

Re: Hero 7 and external mics..... no joy here...

preview.jpg

Adventurer
Posts: 11,264

Re: Hero 7 and external mics..... no joy here...

thank you If you  did exactly what I shown, and you do not have it working, and I own a Rode video Micro, make sure 100% it is  plugged in to the  mic, they are hard to push in themic and rode plug.    the Beats extension you seen me force it on.   Correct I am sure  if my video could not help you but in my photo that is what you got and you need to figure out why yours is not working  

 

Untitled.png