Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Anonymous
Posts: 0

Hero 6 Telemetry Not Showing in Dashware

[ New ]

I just got my Hero 6 and was trying to get the GPS data to show in Dashware, I use the video file as the data file but no data shows in the gauges.  In Quick the same clip will show the data in the gauges.  Any help on how to get Dashware to work?


Accepted Solutions
Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Ok, i have it working.

For others, here is what i did:

 

I installed Dashware 1.9.1 on a laptop with Windows 10 (not running in a Virtual Machine).

Btw. i couldn't use the dashware installer file that i downloaded in de Win7 VM. I downloaded it again in Win10.

 

Than i copied your Hero6GPMF.xml file to C:\Program Files\DashWare\DataTool\DataProfiles

btw. i had to add Write access to this folder (right click folder, Properties, Security tab, add Write permission). This might be specific to my Win10 configuration.

 

Than i start Dashware and do: File --> Quick Project Creator --> select the .MP$ file from the gopro Hero 6 (i deselected Copy file to project directory). --> OK. Now you will see the video, but the telemtry data is not yet there.

 

At Input Settings on the right select --> Data Files: plus (+) sign --> select the video file again --> now you will see a popup windows "Extracting GPMF Data..." (this didn't show up in my Win7 VM on my Apple).

 

When it has finished extracting select the "GoPro" data profile --> and select Add.

 

Now it should work.

 

Btw. if you don't copy in the Hero6GPMF.xml file. It will still show Extracting GPMF data but it will finish extracting much faster and doesn't show telemtry data.

View solution in original post


All Replies
GoPro
Posts: 3,924

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Hi @Anonymous,

 

If you get in touch with our Support Team directly they can take a look at your system and work through some steps that should get you up and running! You can get in touch by Phone or Chat: https://gopro.com/help/ContactUs

 

Cheers,

Ryan

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

I've been trying the same thing all day too.

 

I really don't understand why GoPro decided to embed the data rather than saving it a separate GPX, it makes it so much harder to work with!

 

I'm sure Quik is great if want everything done for you, but personally I hate it. Studio wasn't perfect but it was a lot better! You can't even change the brightness or colour balance in Quik. What's the point of Protune now??

 

Dashware (latest version), doesn't process the embedded data properly for some reason, despite Dashware being owned by GoPro now. It creates a CSV file, and I've tried creating a new data profile to map all the columns - nothing. It should be seamless, but it's just not working at all.

 

It's such a killer feature, yet it's almost pointless because the data is hard to get to and your own software can't read it. Not really what you'd expect from the No1 action camera on the market.

 

Apart from Quik.

Hiker
Posts: 28

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Just wanted to chime in and say I 100% agree with the previous post - the GPS implementation is simply atrocious, why not just give us the data (ideally in a GPX file) and let us do whatever we want to do with it? It's not like you're losing any competitive advantage by storing it in a proprietary format that is a PITA to work with.. Quik may be great for your average consumer but why stop the people who want to use the full potential of the camera from accessing the raw data?

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

I think it's fine to embed the data in whatever format, as long as you can get the data out into something useful.

 

I'm sure it wouldn't be so difficult for Quik to give a simple "Export as GPX" file option.

 

In the meantime, I did find this site via another post which you might find useful:

https://www.trassy.pl/blog/syncloc

 

But it would be nice if I could get the data without having to upload a large file to a third party website.

 

Annoyingly this has been a problem since the Hero5, so it's not a new thing.

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Out of curiousity I tried the free version of Race Render 3 on one of my clips.  It worked great, but I really don't want to pay for a version that gets rid of the logo and lets me make clips longer than 3 minutes.  If GoPro is going to offer a product they should make sure it works as intended without needing a 3rd party.

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]
It's ironic that RR3 works better than Dashware which is owned by GoPro...
Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

La telemetría no funciona para nada. El software es penoso.

He intentado extraer los datos con Dash Ware y el archivo .CSV que genera no lo interpreta para nada. Los videos en Quik aparecen con un signo de interrogacion y no se ve la miniatura y no se pueden editar.

 

Un desastre

Hiker
Posts: 28

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

As far as I'm concerned, this is solved - I can 100% recommend this tool:

 

https://www.trassy.pl/blog/syncloc

 

I worked with the developer over the last couple days and he was able to address everything that I thought could be useful

 

- don't be alarmed by this being an online tool, the processing happens client-side and takes a couple seconds even for 20GB of video

- Once processed, you can export individual GPX files for each of your videos.

- These files can be used in DashWare and work without any adjustements (below is a sample clip)

- You can also load the gpx files into Google Earth or any similar program and easily see where was each of your individual videos taken or conversely, in which file is the video from a given location. 

 

Sample from Dashware using a files exported from Trassy.pl 

 

 

The GPX export is only a small part of the site allows you to do - go check it out.

 

FB - https://www.facebook.com/ruszamy/

 

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]
Does anyone have a solution for the Problem, except for any other software? No Telemtry showing in Dashware with the Hero 6 , does anyone have a guide?
Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

The Solution is:

Install GoPro Quick

copy C:\Program Files\GoPro\GoPro Desktop App\telemetrydata\DataProfiles\Hero6GPMF

to

C:\Program Files\DashWare\DataTool\DataProfiles\

and have fun :-)

Backpacker
Posts: 1,012

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

i've just done that & going to give it a try. Interesting there was a Karma profile in the Quik folder as well, i've copied that hoping for something special from the drone footage

Backpacker
Posts: 1,012

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

well i've just tried it, & made no difference at all. Still can't get Hero 6 data to work :(

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Copying the dataprofile is not working. Looking at the files (GoPro.xml and the Hero6GPMF.xml) i see many similarities in the way the file is constructed. But also many different elements in the file.

DashWare doesn't seem to recognize the profile file from Quick. When i select File --> Edit Data Profile... i get into the profile editor. When i refresh the list, i will not see the Hero6 profile. I do see the default supplied profiles (like GoPro.xml).

 

What is the purpose of this action? Does DashWare only need to have the right profile to understand how to read the telemtry data from the MP4 file? And if so, can you copy your profile file here?

 

 

Kind regards,

Bram

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

ok I Have DashWare ver. 1.9.1 and this file worked for my hero6 videos.

only copy it to: C:\Program Files\DashWare\DataTool\DataProfiles.

 

https://drive.google.com/file/d/1HZZVTXcSBIUFI-AEL9Tcho59YQr_Mbb1/view?usp=sharing

 

 

 

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Thanks for sharing, although the same trick doesn't work for me.

 

I also see a folder Documents\DashWare\DataProfiles. But also when i copy the file over there it doesn't work.

I am using Windows 7 in a VMWare virtual machine on Mac. Don't think it should make a difference, but just to be sure the situation is clear.

 

Did you change anything to the file?

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Ok, i have it working.

For others, here is what i did:

 

I installed Dashware 1.9.1 on a laptop with Windows 10 (not running in a Virtual Machine).

Btw. i couldn't use the dashware installer file that i downloaded in de Win7 VM. I downloaded it again in Win10.

 

Than i copied your Hero6GPMF.xml file to C:\Program Files\DashWare\DataTool\DataProfiles

btw. i had to add Write access to this folder (right click folder, Properties, Security tab, add Write permission). This might be specific to my Win10 configuration.

 

Than i start Dashware and do: File --> Quick Project Creator --> select the .MP$ file from the gopro Hero 6 (i deselected Copy file to project directory). --> OK. Now you will see the video, but the telemtry data is not yet there.

 

At Input Settings on the right select --> Data Files: plus (+) sign --> select the video file again --> now you will see a popup windows "Extracting GPMF Data..." (this didn't show up in my Win7 VM on my Apple).

 

When it has finished extracting select the "GoPro" data profile --> and select Add.

 

Now it should work.

 

Btw. if you don't copy in the Hero6GPMF.xml file. It will still show Extracting GPMF data but it will finish extracting much faster and doesn't show telemtry data.

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Yesss this works to me  in my windows 10 pro  Thanks

Tourist
Posts: 1

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

You are my hero! No idea why GoPro couldn't help me with this but at least there is finally a solution for us 6 users. Thank you!

Anonymous
Posts: 0

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Thank you all for this great thread!!!  So happy there is an option for gauges/overlays outside Quik!  Looks like all my gauges are working except the compass portion of the "GoPro Speedometer" gauge and I wanted to chime in encase anyone else is experiencing this.  Footage is from Hero 6/Karama flight and I was able to get the compass working by selecting the “GoPro Speedometer” in the project gauges section of the project window and then clicking on the “Edit Gauge Input Assignment”.  DW1.png

This opens the input mapper window and under the heading I chose the “GoPro Karma v1.0:VFRH[4] (deg) value and it seems to work well.

DW2.png

There are many parameters listed so I’ll continue to experiment and see if there are others to mess with etc.

Tourist
Posts: 4

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Hallo, mir Gopro 5 get das problem los aber habe gerade mit Gopro 6 versucht und das geht nicht! DashWare ertellt kein CSV. Datei!!!

GoPro
Posts: 19,611

Re: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Hello @dragitaso

 

Sorry to hear about the trouble. See if the steps to fix detailed in this article will help resolve the issue. If not, our Support team will be able to walk you through further steps. You can reach them here https://gopro.com/help/ContactUs

 

Best regards, 

Marius

Tourist
Posts: 4

Betreff: Hero 6 Telemetry Not Showing in Dashware

[ New ]
Hallo Marius, ja ist beschrieben und funktioniert. Das Datei Hero6GPMF.xml muss man von GoPro app zu Dachware kopieren dann gehts!
Danke
GoPro
Posts: 19,611

Re: Betreff: Hero 6 Telemetry Not Showing in Dashware

[ New ]

Awesome! Great to know that it worked, @dragitaso. Thank you for posting back to share.