Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
%3CLINGO-SUB%20id%3D%22lingo-sub-27962%22%20slang%3D%22en-US%22%3EHero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-27962%22%20slang%3D%22en-US%22%3E%3CP%3EUnbelievably%2C%20I%20no%20longer%20have%20a%20WiFi%26nbsp%3B%20%22Turn%20On%20Connection%22%20option%20in%20my%20Connection%20Settings%20menu.%20I%20now%20have%20Connect%20New%20Device%2C%20Camera%20Info%2C%20and%20Reset%20Connection%2C%20but%20no%20turn%20ON%2FOFF%20connection.%20It%20used%20to%20be%20there%20and%20I%20have%20no%20idea%20what%20happened.%20Firmware%20Version%201.50%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20done%20Factory%20and%20Connection%20resets.%20I'm%20at%20a%20loss.%20Any%20ideas%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-27962%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EHERO5%20Session%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-27963%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-27963%22%20slang%3D%22en-US%22%3E%3CP%3EOnce%20you%20reset%20the%20camera%20you%20need%20to%20re%20connect.%20That's%26nbsp%3Bwhy%20it%20only%20shows%20%22connect%20a%20new%20device%22.%20You%20will%20need%20to%20re%20do%20the%20connection%20process%20to%20the%20app%20or%20what%20ever%20you%20want%20to%20connect%20to.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-27967%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-27967%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20the%20reply.%20The%20option%20disappeared%20even%20though%20I%20had%20not%20reset.%20I%20have%20SINCE%20reset%20the%20connection%20and%20the%20factory%20reset%20to%20see%20if%20that%20would%20bring%20it%20back.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%2C%20it%20won't%20connect%20to%20a%20new%20device%20either.%20I've%20tried.%20It's%20like%20it's%20stuck%20on%20the%20old%20one.%20I%20can't%20figure%20out%20how%20to%20break%20out%20of%20this%20loop.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-27968%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-27968%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20also%20deleted%20the%20camera%20in%20the%20App%20and%20tried%20from%20scratch%20%22Add%20Camera.%22%20I%20get%20the%20blue%20light%20on%20the%20cam%2C%20and%20the%20blue%20wifi%20symbol%2C%20and%20a%20constant%20return%20to%20the%20password%20entry%20screen%20in%20the%20App%2C%20as%20though%20I'm%20typing%20it%20wrong.%20I'm%20not!!!%20%3A(%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-28367%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-28367%22%20slang%3D%22en-US%22%3E%3CP%3EHey%20%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F15141%22%20target%3D%22_blank%22%3E%40epicridge25715%3C%2FA%3E%2C%20you'll%20need%20to%20input%20your%20password%20for%20the%20camera%20in%20your%26nbsp%3BWi-Fi%20settings%20of%20your%20phone%2C%20on%20the%20network%20of%20the%20camera%2C%20not%20in%20the%20App.%20In%20the%20App%20you%20need%20to%20put%20in%20your%20GoPro%20account%20password.%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EI%20hope%20that%20helps!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-28589%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-28589%22%20slang%3D%22en-US%22%3E%3CP%3EI%20actually%20got%20it%20to%20work%20with%20a%20combination%20of%20resets%20and%20adding%20new%20devices%2C%20etc.%20I%20still%20have%20no%20idea%20why%20I%20lost%20that%20menu%20item.%20I%20had%20been%20getting%20sudden%20video%20breakup%20at%201080P30%20and%20so%20I%20began%20poking%20around.%20That's%20when%20I%20discovered%20I%20couldn't%20connect%20via%20the%20App.%20Seems%20to%20be%20working%20now%2C%20except%20for%20the%20poor%20battery%20issues.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-34807%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-34807%22%20slang%3D%22en-US%22%3E%3CP%3EWait%20I'm%20having%20the%20same%20exact%20problem%20you%20did.%20I%20dont%20have%20that%20turn%20connection%20on%2Foff%20menu%20option%20on%20my%20hero%205%20session%20go%20pro%20anymore%20and%20i%20cant%20add%20my%20camera%20to%20the%20capture%20app.%20the%20wifi%20icon%20isnt%20showing%20up%20on%20my%20screen.%20ive%20tried%20to%20reset%20the%20connection%20multiple%20times%20but%20when%20i%20go%20to%20join%20the%20wifi%20on%20my%20iphone%2C%20I%20cant%20connect%20and%20all%20the%20wifi%20bars%20are%20grey%2C%20not%20black.%20can%20you%20please%20please%20please%20tell%20me%20what%20you%20did%20to%20connect%20your%20go%20pro%3F%20Its%20diving%20me%20crazy.%3C%2FP%3E%3CP%3EThank%20you!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-34818%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-34818%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F20647%22%20target%3D%22_blank%22%3E%40toughcave5884%3C%2FA%3E%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EI%20believe%20I%20can%20explain%20what%20happened%20in%20your%20case.%20%26nbsp%3BThe%20%22Turn%20connection%20on%2Foff%22%20option%20will%20disappear%20when%20you%20reset%20the%20wi-fi%20connection%20on%20your%20HERO5%20Session%2C%20and%20the%20camera%20will%20not%20be%20able%20to%20connect%20to%20the%20Capture%20app%20using%20the%20connection%20info%20you%20had%20set%20up%20before.%20%26nbsp%3BThis%20is%20because%20when%20you%20reset%20the%20wi-fi%20connection%2C%20the%20camera%20is%20given%20a%20new%20name%20and%20password%2C%20so%20the%20old%20connection%20info%20will%20not%20work.%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EIn%20this%20case%2C%20you%20would%20simply%20need%20to%20delete%20the%20info%20for%20your%20camera%20from%20Capture%2C%20remove%26nbsp%3Bthe%20bluetooth%20listing%20from%20your%20settings%2C%20and%20set%20up%20the%20connection%20as%20new%20again.%20%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3ECheers!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-34894%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-34894%22%20slang%3D%22en-US%22%3E%3CP%3Eive%20tried.%20i%20removed%20the%20camera%20from%20bluetooth%20and%20reinstalled%20the%20capture%20app%2C%20and%20I%20tried%20to%20reconnect%20the%20camera%20again%2C%20but%20it%20still%20isnt%20letting%20me%20connect%20to%20the%20cameras%20wifi.%20and%20the%20wifi%20icon%20still%20isnt%20showing%20up%20on%20my%20go%20pro%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-39228%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-39228%22%20slang%3D%22en-US%22%3E%3CP%3EIve%20got%20the%20same%20issue.%20Deleted%20the%20app%20and%20tried%20resetting%20everything%20from%20the%20bottom%20up.%20Even%20factory%20reset%20the%20camera.%20When%20I%20go%20to%20connect%20there%20is%20no%20wifi%20signal%20from%20the%20camera.%20There%20is%20no%20wifi%20icon%20on%20the%20screen.%20There%20is%20no%20option%20to%20turn%20on%20the%20connection.%20I%20have%20tried%20connecting%20with%203%20different%20devices%20but%20none%20of%20them%20see%20a%20wifi%20signal%20from%20the%20camera.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20ever%20find%20a%20solution%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-39998%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%205%20Session%20No%20%22turn%20on%20connection%22%20option!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-39998%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20exactly%20the%20same%20issue%20here.%20Happened%20with%20previous%20firmware%20version%20and%20with%20the%20latest%20one%20(2.0)%20it's%20still%20happening.%3C%2FP%3E%3CP%3EIt's%20driving%20me%20crazy%20for%20several%20days%20already.%20No%20option%20to%20%22Turn%20ON%20connections%22%2C%20it%20goes%20straight%20to%20%22Connect%20New%20device%22.%3C%2FP%3E%3CP%3EAnyone%20has%20a%20solution%20please%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Reply
Highlighted
Tourist
Posts: 7
Accepted Solution

Hero 5 Session No "turn on connection" option!

Unbelievably, I no longer have a WiFi  "Turn On Connection" option in my Connection Settings menu. I now have Connect New Device, Camera Info, and Reset Connection, but no turn ON/OFF connection. It used to be there and I have no idea what happened. Firmware Version 1.50

 

I've done Factory and Connection resets. I'm at a loss. Any ideas?


Accepted Solutions
GoPro
Posts: 80

Re: Hero 5 Session No "turn on connection" option!

Hi @toughcave5884

 

I believe I can explain what happened in your case.  The "Turn connection on/off" option will disappear when you reset the wi-fi connection on your HERO5 Session, and the camera will not be able to connect to the Capture app using the connection info you had set up before.  This is because when you reset the wi-fi connection, the camera is given a new name and password, so the old connection info will not work.

 

In this case, you would simply need to delete the info for your camera from Capture, remove the bluetooth listing from your settings, and set up the connection as new again.  

 

Cheers!

View solution in original post


All Replies
Nomad
Posts: 130

Re: Hero 5 Session No "turn on connection" option!

Once you reset the camera you need to re connect. That's why it only shows "connect a new device". You will need to re do the connection process to the app or what ever you want to connect to.

Tourist
Posts: 7

Re: Hero 5 Session No "turn on connection" option!

Thanks for the reply. The option disappeared even though I had not reset. I have SINCE reset the connection and the factory reset to see if that would bring it back.

 

Also, it won't connect to a new device either. I've tried. It's like it's stuck on the old one. I can't figure out how to break out of this loop.

Tourist
Posts: 7

Re: Hero 5 Session No "turn on connection" option!

I've also deleted the camera in the App and tried from scratch "Add Camera." I get the blue light on the cam, and the blue wifi symbol, and a constant return to the password entry screen in the App, as though I'm typing it wrong. I'm not!!! :(

GoPro
Posts: 1,753

Re: Hero 5 Session No "turn on connection" option!

Hey @epicridge25715, you'll need to input your password for the camera in your Wi-Fi settings of your phone, on the network of the camera, not in the App. In the App you need to put in your GoPro account password. 

 

I hope that helps!

Tourist
Posts: 7

Re: Hero 5 Session No "turn on connection" option!

I actually got it to work with a combination of resets and adding new devices, etc. I still have no idea why I lost that menu item. I had been getting sudden video breakup at 1080P30 and so I began poking around. That's when I discovered I couldn't connect via the App. Seems to be working now, except for the poor battery issues.

 

Thanks!

Tourist
Posts: 8

Re: Hero 5 Session No "turn on connection" option!

Wait I'm having the same exact problem you did. I dont have that turn connection on/off menu option on my hero 5 session go pro anymore and i cant add my camera to the capture app. the wifi icon isnt showing up on my screen. ive tried to reset the connection multiple times but when i go to join the wifi on my iphone, I cant connect and all the wifi bars are grey, not black. can you please please please tell me what you did to connect your go pro? Its diving me crazy.

Thank you!

GoPro
Posts: 80

Re: Hero 5 Session No "turn on connection" option!

Hi @toughcave5884

 

I believe I can explain what happened in your case.  The "Turn connection on/off" option will disappear when you reset the wi-fi connection on your HERO5 Session, and the camera will not be able to connect to the Capture app using the connection info you had set up before.  This is because when you reset the wi-fi connection, the camera is given a new name and password, so the old connection info will not work.

 

In this case, you would simply need to delete the info for your camera from Capture, remove the bluetooth listing from your settings, and set up the connection as new again.  

 

Cheers!