Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Sightseer
Posts: 1

Hero 4 connection issues

[ New ]

Hi!

Just recently i dug up my HERO 4 Black so i can film my trip to Vietnam, but ive stumbled across a problem.

I cannot seem to connect my camera to any sort of device. There are 2 main issues.

 

First one is that whenever i go into the setting and atempt to turn on the Wireless setting, it immediately turns off. Not the camera, the setting, i set it to ON, confirm it, go back to the previous menu and its still on OFF and the blue light isnt blinking. From what ive searched for online, people tell me that i need to pair my gopro, but thats where the second issues comes in.

 

Whenever i attempt to pair the HERO 4 with my phone, the phone just says We Cant Find Your GoPro. The pairing code apears, the blue light flashes, but not mine, neither my friends devices can pair with my camera. Do you have any idea what could be causing the problem? Ive tried reseting the camera to factory setting, reseting my phone connection setting, updating the camera, but nothing works. Do i need to get a new camera?

 

Thanks


Accepted Solutions
GoPro
Posts: 23,053

Re: Hero 4 connection issues

[ New ]

Hi @noblebeach0347

 

Try to reset the Wi-Fi settings:

  1. With the camera ON, press and hold the Settings button (on the side) for 2 seconds until the Wi-Fi Mode options appear.
  2. While still holding the side button, press and release the Power/Mode button (front).
  3. Select Reset in the 'Reset Wi-Fi Settings' option.

Once done, proceed with the pairing process

Should it still be the same, please go over GoPro App Camera Connection Troubleshooting

 

Let us know how it goes.

You may also reach out to our Support Team for assistance through https://gopro.com/help/ContactUs   

 

Thanks!

Ej

View solution in original post


All Replies
GoPro
Posts: 23,053

Re: Hero 4 connection issues

[ New ]

Hi @noblebeach0347

 

Try to reset the Wi-Fi settings:

  1. With the camera ON, press and hold the Settings button (on the side) for 2 seconds until the Wi-Fi Mode options appear.
  2. While still holding the side button, press and release the Power/Mode button (front).
  3. Select Reset in the 'Reset Wi-Fi Settings' option.

Once done, proceed with the pairing process

Should it still be the same, please go over GoPro App Camera Connection Troubleshooting

 

Let us know how it goes.

You may also reach out to our Support Team for assistance through https://gopro.com/help/ContactUs   

 

Thanks!

Ej