Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Sightseer
Posts: 3

HOW CAN I CONTACT SUPPORT?

[ New ]

Tried to get in touch with the support using this form: https://de.gopro.com/help/ContactUs.

When i click "Chat" i get an error message saying: "Chat is currently unavailable for you."

When i choose call back i says: "Invalid Captcha. Please retry." - but i was never asked to enter a captcha!

 

It´s kind of urgent because my GoPro Hero7 is broken...

 

Anyone knows how to contact them?

GoPro
Posts: 19,860

Re: HOW CAN I CONTACT SUPPORT?

[ New ]

Hello @r3n3lang3. How are you contacting Support? Are you using a mobile phone or a computer? Did you contact Support during the hours of operation indicated on the contact page? Have you set the country correctly before you put in your contact number? A screenshot of the page that you are getting will be helpful. We hope to hear back from you. Thanks!

Sightseer
Posts: 3

Re: HOW CAN I CONTACT SUPPORT?

[ New ]

Hi,

tried to contact them from a computer using 3 different browsers (Firefox 72.0.2, Chrome 80 and Edge).

Language is set to german and it´s within their hours.

Screenshot is attached...

Anmærkning 2020-02-11 174903.png
Sightseer
Posts: 3

Re: HOW CAN I CONTACT SUPPORT?

[ New ]
 
Anmærkning 2020-02-11 180238.png
GoPro
Posts: 6,097

Re: HOW CAN I CONTACT SUPPORT?

[ New ]

Hi @r3n3lang3,

 

If you really can't contact German customer support, please try to contact English US customer support team. 

You can change your country and language by clicking the globe icon on the upper right hand side of GoPro's website.

Please choose United States English then contact them again. 

 

-Jay

Adventurer
Posts: 13,903

Re: HOW CAN I CONTACT SUPPORT?

[ New ]

Could we not simply Default the Contact us, as many report the same issue over and over and over and over again. seems to be  the  members issues or gopro issue