Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Tourist
Posts: 3

Gopro Hero9 black set up live issue

[ New ]

I went through the twitch authorization steps on my phone to allow me to set up live streaming on my Hero9 Black but whenever i attempt to use it i get a message saying "allow twitch sorry something went wrong. Please try again." with a cancel and allow button. The allow button just keeps recycling the same pop up and cancel returns me to the Live options menu. I seem to catch it saying wifi disconnected right as i select twitch to go live on before it gives me the error. 

 

Could use some advice/

 

thanks!

GoPro
Posts: 25,955

Re: Gopro Hero9 black set up live issue

[ New ]

Hi @drrhino

 

What phone are you using?

What version is the app on?

Do you observe the same when using a different platform? Ex. Facebook, YouTube

See if restarting your phone will help.

 

Thanks!

Ej

Tourist
Posts: 3

Re: Gopro Hero9 black set up live issue

[ New ]
Hi there!

I'm using a galaxy so
The app version is 8.4
I and I didn't test the other platforms for streaming.
GoPro
Posts: 13,438

Re: Gopro Hero9 black set up live issue

[ New ]

Thanks for the info, @drrhino. Just to further check, have you been able to set up live streaming to Twitch before?

 

What's the Android version installed on your phone?

Make sure your mobile device and camera are also on their current versions.

In addition, please try to unpair and re-pair your camera to the app. Clearing the cache for the app in your device's settings under the "Applications" section can also help. Some phones and regions also require the camera to be in a 2.4GHz Wi-Fi band.

 

Let us know how it goes.

Tourist
Posts: 3

Re: Gopro Hero9 black set up live issue

[ New ]
Hi!
So I checked my phone version and everything was up to date.
I cleared my app data and reset my connection. I performed my 2 factor authentication for Twitch successfully, and after selecting "authorize" i got the above error again.
I thought maybe the 2 factor was the issue, so I disabled the 2 factor, cleared my data and did it all again and the same thing happened. I also tried setting up live with YouTube and everything was authorized but the loading wheel was perpetually spinning with nothing happening.

Suggestions on next steps?
GoPro
Posts: 25,955

Re: Gopro Hero9 black set up live issue

[ New ]

Thanks for getting back to us @drrhino

We'll have this shared with the team.

We'll post back once we have an update.