Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
Posts: 1

Gopro Hero 7 Black - no/lost media but storage still utilised

Hi All,

Tried looking for a similar topic but could not find one.

I recorded a bunch of videos on my Hero 7 last month and today I switched the GoPro on in hope to re-watch & transfer the clips to my laptop.

However, when I switched it on, the GoPro told me that there NO MEDIA but SD Card is 1/3 used up. I’m using a Samsung SD Card which has worked fine in the past.

I then inserted the SD Card to my laptop and again, it showed NO MEDIA but the SD has x GB used up.

I have tried using various data recovery applications and they have all succeeded to identify the lost media but the issue is that the videos are corrupt, therefore, won’t play.

Ha anyone faced similar issues? When I search in the forum, I can see a lot of people having corrupt videos situations but couldn’t find anyone facing the same problem as me, I.e. GoPro says no media but storage is still utilised.

Would appreciate any help - got some really important videos on there!

Posts: 3,237

Re: Gopro Hero 7 Black - no/lost media but storage still utilised

Sounds like your SD card is corrupt,  Have you tried putting it into your pc, right clicking on it, selecting tools and "scan disc for errors"?