Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Tourist
Posts: 4

GoPro plus upload error #604

[ New ]
I just purchased a GoPro plus subscription for my hero 7 black. I set up the auto upload with my home WiFi. But during auto uploading the camera shows a message UPLOAD ERROR 604. I am not able to upload any media on GoPro plus cloud manually or automatically. Pls advise. Thanks.
Tourist
Posts: 4

Re: GoPro plus upload error #604

[ New ]
 
Tourist
Posts: 4

Re: GoPro plus upload error #604

[ New ]
??
GoPro
Posts: 20,523

Re: GoPro plus upload error #604

[ New ]

Hello @nicecave58555. Sorry to hear about the trouble. Were you getting the same error message when you attempted other methods of uploading media to the cloud? Which media are these - videos? photos? chaptered videos

A screenshot of the error message that you were getting would be helpful. If you haven't tried them all yet, see if any of the methods detailed here  will allow successful Plus upload. Let us know what you find out. 

Sightseer
Posts: 1

Re: GoPro plus upload error #604

[ New ]
I'm having the same issue.. Not sure What To do now?
Tourist
Posts: 2

Re: GoPro plus upload error #604

[ New ]

I'm also getting this error code with my brand new Hero 7 - the support from GoPro is woeful.  I've searched on line through Google and GoPro and no workable solutions.  I can't manually upload or auto upload to the GoPro+ Cloud.  Same error code on the camera; connected to home wi-fi; collection of video (some with highlights) and stills; GoPro software up-to-date.  Trying to get the auto upload set-up in the first place is overly complicated too.  Come on GoPro - get this sorted!

Tourist
Posts: 4

Re: GoPro plus upload error #604

[ New ]
So today morning when I switched on my GoPro the 604 error magically disappeared!! But still the connection was breaking in between and couldn't upload the files yet!! GoPro plus has a lot of glitches I guess.. their tech team needs to step in big time on this!! It's bugging
GoPro
Posts: 20,523

Re: GoPro plus upload error #604

[ New ]

Thank you for the update, @nicecave58555. @nick75-We just tested the Auto Upload feature and we are able to successfully upload both photos and videos to the cloud. In the test we used an Android device running on Android 9 with version 5.2.2 of the GoPro app installed. Camera waited until it was charged at least 80% before it started with the Auto Upload process. 

 

In which part of the process do you see the error message? To gather more details regarding the issue, let us know if you get the same result with uploading using other methods

 

@froomesusa - What seems to be the issue with the manual upload? Are both photos and videos not uploaded at all? When you add media manually through plus.gopro.com , do you get the loading bar indicating upload progress? 

 

We hope to hear back from you. All additional details that you can provided will help us further isolate the issue and help you better. Many thanks!

Tourist
Posts: 2

Re: GoPro plus upload error #604

[ New ]

Thank you for the reply @mariustanya .  The issue was (it worked perfectly last night!) that nothing was uploading automatically (plugged in to power, battery 100% charged, connected to 5GHz wifi).  I was therefore trying to force an upload by touching manual upload.  The device would then say it was starting the upload, with a connecting message below, and then pause for a few minutes before coming up with the error code.  At no stage did I get the loading bar/count down of progress.The files were mostly video clips (one single photo).  I had reset connections, reset wifi all to no avail.  The main point was that there is no list of error codes and what they mean!  Since it has now worked, I can only assume that there was an issue at the server end (since I was not the only one).

Highlighted
GoPro
Posts: 20,523

Re: GoPro plus upload error #604

[ New ]

I appreciate the update, @froomesusa. Great to know that the upload finally worked. We are observing some issues with uploading to cloud - particularly with long videos or those that result to chaptered ones and we are constantly submitting feedback to the teams for a closer look. The results that you shared are helpful. We will check with the team regarding the error codes or notifications and we will definitely provide an update once we have new information. Feel free to post back should have further observations on GoPro Plus behavior. Thanks!