Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
Posts: 10

GoPro Plus Auto-Upload Wi-Fi Problem

[ New ]

After doing a cursory search in the various groups here, it looks like most folks with Auto-Upload Wi-Fi issues are on the Hero 5 or earlier.


I'm on a Hero 6 Black, and am successfully able to pair my iPhone with my camera, no issues. So we know the radio is working for both Bluetooth (initial pairing) and Wi-Fi (the connection itself).


Although I'm usually not a cloud-saving type of guy, I figured for the work I'm doing (backyard wildlife fun) I could use the auto-upload feature and have usable 1080 footage right on my computer to scrub through before copying the higher-resolution video.


When I try to connect to either of my two Apple Airport Extreme routers (current version, both running the latest firmware), on either the 2.4 or 5 GHz bands, I'm getting the same issue:


Connecting...Network authentication failed.


Things I've tried:


1) Subscribed to the GoPro Plus subscription.

2) Contacting GoPro support. (This is day one of owning the camera.)

3) Rebooted routers.

4) Reset camera to factory defaults.

5) Signed out and back in again to my GoPro account in the GoPro app on my iPhone.

6) Verified that I am using the correct password for each router.  (I have manually typed the passwords and used copy and pasted from my password manager to verify - multiple times.)

7) My routers are both:

  * Using WPA2 Personal security settings with passphrases containing spaces, periods, an exclamation mark and a question mark. (Note: all of my many wireless devices work with these passphrases with no problem - and are okay by RFC standards.)

  * Broadcasting SSID (one for each frequency band) - and I can see each of these listed in the Wi-Fi Networks selection page.

  * Not filtering by MAC/hardware address (any device that knows the password can connect).

  * Delegating DHCP to my server, which has a log, and I can see that the camera is not successfully connecting to either router.

8) Set-up a wireless hotspot on my phone with a very basic password (like "abcd1234") and that works. I've even tried using a more complex password ("abcd!1234" and "abcd 1234").


So at this point, I've stumped the first line of GoPro tech support and am expecting an email back.


Any tips?  I'm fairly competent with technology, and am willing to try any reasonable thing.

It feels like a GoPro Wi-Fi bug to me, but it's difficult to prove right now.



Posts: 10

Re: GoPro Plus Auto-Upload Wi-Fi Problem

[ New ]

Oh, I know, replying to myself....


Anyway, I did some more testing with different passwords on my iPhone's hotspot:


Works (31 characters):
Abc! Def? Ghi! Jkl? Mno! Pqr? S

Fails (32 characters):
Abc! Def? Ghi! Jkl? Mno! Pqr? St


SO, I think we have a Wi-Fi passphrase length bug/limitation. (It appears spaces and special characters I used are fine.)


Anyone else have the same issue?


FYI: My actual Wi-Fi password is 47 characters.  RFC states that you can have up to 63 alpha numeric characters, I believe?

Posts: 10

Re: GoPro Plus Auto-Upload Wi-Fi Problem

[ New ]

For those curious (engineers?), the resulting hex output, when you take the SSID of a router and a passphrase between 8 and 63 characters long, you ALWAYS get a 64 digit hexadecimal output, regardless of the size of your passphrase, your PSK (pre-shared key) is always 64 hexadecimal digits:


I tried using the 64 hex digits as a workaround and it failed.


SO, I'm not sure if it's an input/memory/calculation/presentation problem, but I'm guessing this is a GoPro engineering problem, and if anyone else has any ideas or knowledge about this issue, that would be fantastic.


I created this threat so that if there are people using ASCII passphrases longer than 31 characters, OR if they are trying to use the resulting 64 hexadecimal characters, both will fail, and here's why.



Posts: 240

Re: GoPro Plus Auto-Upload Wi-Fi Problem

[ New ]

Hey @amarand,


I sent you a direct message to take this particular issue offline. Can you please respond to the message so I can contact you? Thanks!


~ Mowens