Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Tourist
Posts: 3

GoPro 9 with media mod forgets mic setting

[ New ]

I've got the GoPro 9 with the media mod as well as the max lens mod.  

 

When I use the mic and tell it to use the front mic, it works great.  When I turn the camera off and backj on, I have to tell the camera EVERY TIME to use the front mic.  It seems like it should either remember the setting, or have somewhere to set the front mic as the default instead of the camera mic.

 

If I'm missing something- highly possible as this is my first GoPro - please pass along what I'm missing!

 

GoPro
Posts: 29,888

Re: GoPro 9 with media mod forgets mic setting

[ New ]

Hi @tmaogap

 

What version is the camera on?

It should keep the last option selected on the preset.

 

Thanks!

Ej

Tourist
Posts: 3

Re: GoPro 9 with media mod forgets mic setting

[ New ]

I'm on version 1.22

GoPro
Posts: 29,888

Re: GoPro 9 with media mod forgets mic setting

[ New ]

Hi @tmaogap

 

See if re-flashing the software will help.

Please follow the manual update steps on https://gopro.com/en/us/update/hero9-black

Let us know how it goes.
If it's still the same, please reach out to our Support Team through https://gopro.com/help/ContactUs

 

Thanks!

Ej
 

Tourist
Posts: 3

Re: GoPro 9 with media mod forgets mic setting

[ New ]

I can recreate the issue every time, and it’s specific to the Max Lens Mod Enabled setting.

 

Without max lens mod enabled, I have “Media Mod” selected for my lower right hand corner shortcut using the “Activity” preset.  If I use the “Media Mod” shortcut and select “Front” to use the front facing mic, it is set properly and works as expected.  If I turn the GoPro off and then back on and access the “Media Mod” shortcut, it remembers that it was last using the “Front” mic, as you would expect.

 

Now if I set my GoPro to use my Max Lens Mod kit by selecting “Max Lens Mode Enabled” and mount my Max Lens, things are different.  After selecting the “Max Video” preset and changing the lower right hand corner shortcut to “Media Mod” here’s what happens.  Once I select the mic I want to use – front, rear or camera mic – it’s set – until I turn the GoPro off and back on.  Once I turn the GoPro off and back on, it forgets the previous mic setting and defaults to “Camera Mics” ignoring the media mod setting. 

 

Although not a HUGE issue, it is frustrating, as I’ve fallen in love with that max lens mod kit.  And when we’re VLogging I always have to remember to make sure the front mic is set.  It would be nice to have this fixed if at all possible.

 

So, do I need to log this bug in a separate forum for GoPro to fix in a future firmware update?

GoPro
Posts: 29,888

Re: GoPro 9 with media mod forgets mic setting

[ New ]

Thanks for the clarification. @tmaogap

I was able to replicate the issue with the Max Lens Mod.

 

We'll have this shared with the team.

We'll post back once we have an update.

 

Regards,

Ej

 

Nomad
Posts: 138

Re: GoPro 9 with media mod forgets mic setting

[ New ]

Update slated for Dec 2025.. 

GoPro
Posts: 29,888

Re: GoPro 9 with media mod forgets mic setting

[ New ]

Hello @tmaogap

 

Sorry for the delay in getting back to you.

Please run a manual update, https://gopro.com/en/us/update/hero9-black

After the update is completed, reset the camera. Go to Preferences> Reset> Factory Reset

Do a test recording and see if the same is still observed.

 

I no longer observe this on my camera.

 

Thanks!

Ej

 

Sightseer
Posts: 3

Re: GoPro 9 with media mod forgets mic setting

[ New ]

Hello.

 

Same thing happened to me with the Media Mod.

 

I do youtube videos, so I was writing this whole review of the media mod, talking about how it sucks that you have to keep turning the mic on. It ruined like 5 of my gopro vlog videos because it is hard to remember every time to turn it on.

 

All of a sudden...It works every time. I don't know exactly what was done to fix the issue. I've actually tried to recreate the problem you are having for my video, and couldn't re-create it. Every time I turn on the camera with the media mod and/or with the max lens, I see the audio meter on the screen now.

 

I know this doesn't give you the solution, but just wanted to let you know that there may be a way to fix it and that it isn't completely defective or anything. I'll try today to help and  find the cause if GoPro can't.

 

-CMC

Sightseer
Posts: 3

Re: GoPro 9 with media mod forgets mic setting

[ New ]

Ok, so now this is hilarious.

 

So now, first time I turned on Max Lens mic worked. 

 

Then I turned off the camera, and back on, and Max Lens mics didn't work. However, when I went to Timelapse and then back to Video, the mic was now working (without going into audio settings, just by switching modes). Not an acceptable solution.

 

So now I think it never did work. It only works when activating Max Lens mode from a previous mode, or by turning on then switching between timelapse and video or by going in and changing the mic setting.

 

So I'm still having the same problem GoPro.

Sightseer
Posts: 3

Re: GoPro 9 with media mod forgets mic setting

[ New ]

UPDATE: Fixed (for now) after the December firmware update