Ask a Question
GoPro Support Hub Find a solution. Share a solution. Ask a question. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
%3CLINGO-SUB%20id%3D%22lingo-sub-372159%22%20slang%3D%22en-US%22%3EGo%20pro%20says%20no%20SD%20card%20when%20SD%20card%20is%20installed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-372159%22%20slang%3D%22en-US%22%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-372159%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EHERO%20Session%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-372167%22%20slang%3D%22en-US%22%3ERe%3A%20Go%20pro%20says%20no%20SD%20card%20when%20SD%20card%20is%20installed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-372167%22%20slang%3D%22en-US%22%3E%3CP%3ECould%20be%20a%20faulty%20SD%20card%2C%20try%20a%20different%20card%20and%20see%20if%20that%20works.%3C%2FP%3E%3CP%3ETry%20reloading%20the%20firmware%20onto%20the%20camera%20see%20if%20that%20works.%3C%2FP%3E%3CP%3EIf%20neither%20of%20the%20above%20work%2C%20then%20it's%20possible%20the%20SD%20card%20slot%20has%20dirty%20contacts%20and%20isn't%20reading%20your%20card%20properly%2C%20see%20if%20you%20can%20get%20an%20SD%20card%20slot%20cleaner.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20all%20the%20above%20fail%2C%20then%20you%20could%20have%20a%20camera%20fault%2C%20I%20experienced%20the%20same%20with%20a%20GP4%20and%20the%20mainboard%20had%20to%20be%20replaced.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Reply
Highlighted
Sightseer
Posts: 1

Go pro says no SD card when SD card is installed

 
Nomad
Posts: 891

Re: Go pro says no SD card when SD card is installed

Could be a faulty SD card, try a different card and see if that works.

Try reloading the firmware onto the camera see if that works.

If neither of the above work, then it's possible the SD card slot has dirty contacts and isn't reading your card properly, see if you can get an SD card slot cleaner.

 

If all the above fail, then you could have a camera fault, I experienced the same with a GP4 and the mainboard had to be replaced.