Ask a Question
GoPro Support Hub Find a solution. Share a solution. Ask a question. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
%3CLINGO-SUB%20id%3D%22lingo-sub-374015%22%20slang%3D%22en-US%22%3EGo%20pro%207%20just%20lost%20HDMI%20no%20Signal%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-374015%22%20slang%3D%22en-US%22%3EWas%20on%20TV%20Screen.%20Won%E2%80%99t%20connect%3F%20From%20receiver%20them%20plugged%20directly%20into%20tv%20an%20still%20no%20picture.%20Turned%20off%20equipment%20back%20on.%20Nothing%3F%20Took%20battery%20out%20and%20put%20back%20in%3F%20Nothing%3F%20But%20works%20on%20LCD%20screen%20on%20the%20go%20pro%207%3F%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-374015%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EHERO7%20Black%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-374165%22%20slang%3D%22en-US%22%3ERe%3A%20Go%20pro%207%20just%20lost%20HDMI%20no%20Signal%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-374165%22%20slang%3D%22en-US%22%3E%3CP%3EHave%20you%20tried%20plugging%20the%20camera%20directly%20into%20your%20TV%20and%20bypassing%20the%20receiver%3F%26nbsp%3B%20Is%20the%20camera%20region%20set%20up%20to%20match%20the%20TV%20region%3F%26nbsp%3B%20Have%20you%20tried%20using%20a%20different%20HDMI%20cable%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Reply
Tourist
Posts: 2

Go pro 7 just lost HDMI no Signal

Was on TV Screen. Won’t connect? From receiver them plugged directly into tv an still no picture. Turned off equipment back on. Nothing? Took battery out and put back in? Nothing? But works on LCD screen on the go pro 7?
Nomad
Posts: 777

Re: Go pro 7 just lost HDMI no Signal

Have you tried plugging the camera directly into your TV and bypassing the receiver?  Is the camera region set up to match the TV region?  Have you tried using a different HDMI cable?

 

 

GoPro
Posts: 8,398

Re: Go pro 7 just lost HDMI no Signal

Tourist
Posts: 2

Re: Go pro 7 just lost HDMI no Signal

Yes I went and bought a new HDMI Cable at Best Buy. Plugged it in worked great. 2 weeks later I went to play some videos. Came on no problem through Receiver. I put the go pro on the coffee table and lost video? I tried to plug and unplug. Turn off camera, receiver and turn back on. Unplug battery restart. Nothing Tried directly to the TV screen will change to Black but no visual data or picture from GoPro. Checked settings? Nothing! I can play video on the back screen of the GoPro!
GoPro
Posts: 7,382

Re: Go pro 7 just lost HDMI no Signal

Hello @redcrest0517. Which HDMI input were the GoPro set to this time?  Also, do you recall any change on the video resolution used? Were you trying to view the same video, or new videos? Try using a different port on the TV, if available, and make sure to set the connection to the correct Input. 

 

By the way, a new firmware for the HERO7 Black was released yesterday. Be sure to update your camera. Firmware download is available at https://gopro.com/en/ph/update/hero7-black .