Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Sightseer
Posts: 3

GOPRO 7 USB / MTP connection

[ New ]

Hi All,

 

I went thorugh most of stuff on forum and YT and non helped with my case.

 

I connect GP Black 7 to my computer with updated Win10.

I appears in File Explorel as: Device MTP USB

 

Under Device Manager i have to records:

1st: Other Devices -> Unknown device

2nd Portable devices -> device MTP USB

 

Gopro Quick is not detectin camera and that is my biggest concern.

gp1.PNG

Accepted Solutions
GoPro
Posts: 6,097

Re: GOPRO 7 USB / MTP connection

[ New ]

Hi @pawell514,

 

Please make sure you're using a recommended SD card brand and model. 

https://gopro.com/help/articles/block/microSD-Card-Considerations

Download and install new firmware update manually: https://gopro.com/help/articles/block/How-to-Update-GoPro-Cameras

 

After that, try to delete MTP USB driver or uninstall USB driver. 

Restart your PC and connect your camera and check if it will now be detected. 

 

You can also watch this: https://www.youtube.com/watch?v=uem6BbNEj-I

 

 

-Jay

View solution in original post


All Replies
Sightseer
Posts: 3

Re: GOPRO 7 USB / MTP connection

[ New ]

and second screen

gp2.PNG
GoPro
Posts: 6,097

Re: GOPRO 7 USB / MTP connection

[ New ]

Hi @pawell514,

 

Please make sure you're using a recommended SD card brand and model. 

https://gopro.com/help/articles/block/microSD-Card-Considerations

Download and install new firmware update manually: https://gopro.com/help/articles/block/How-to-Update-GoPro-Cameras

 

After that, try to delete MTP USB driver or uninstall USB driver. 

Restart your PC and connect your camera and check if it will now be detected. 

 

You can also watch this: https://www.youtube.com/watch?v=uem6BbNEj-I

 

 

-Jay

Sightseer
Posts: 3

Re: GOPRO 7 USB / MTP connection

[ New ]

I did it.

Good thing is - sd card inserted via card reader works with GP Quick.

Bad thing is - Camera connected directly still works as in oryginal post.

 

Any furhter tips  how to solve it?