Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Highlighted
Hiker
Posts: 7

Cannot Upload to GoPro Plus

This has been such a frustrating experience. Rather than trying to isolate what I think are a myriad of problems, I have decided to present a moment in the life of trying to synchronize the various GoPro hardware, software and web based elements. It is long. I would not really expect anyone to read it all the way through but I am at a loss.  So, here goes ...

 

The only instructions I found for uploading the the cloud were

All of the steps up to step 7 of the Initial Setup have been done (some more than once). Step 7 says

 

  • Connect your camera to a wall charger with an output of 5V 2A (5V 1A minimum). When the battery is charged, the automatic upload to the cloud will begin.

I have also done this more than once (much more than once), but I am going to do it again. I believe I now know the drill well enough that I can do it and record it accurately.

 

My camera is connected to my home network.

 

My GoPro app is on what I will call the "Camera" page with a pencil icon in the upper right corner and an "X" in the upper right hand corner and a picture of a camera with a wireless icon to the right and the camera name and media, camera and cloud icons below.

 

My GoPro app seems to be connected (via the Cloud icon I connect to the network but I get no positive feedback that the connection is successful). On the "Camera" page there is a wireless icon to the right of the camera picture and I assume this means the GoPro app is connected.

 

I unplug my camera from the charger so that the battery will drain a bit. I do this so that I can perform step 7 above with a battery that is less than fully charged. I assume the battery must be less than fully charged so that the GoPro can detect when it become fully charged.

 

I wait. It doesn't take long for the battery to drain. It is now at 96%.

 

The GoPro app is connected to my home network. All steps prior to step 7 in Auto Uploading Your Footage to the Cloud With GoPro Plus are done. The camera's battery is now at 94%. I plug the camera into the charger. A camera chargin

 

A STARTING UPLOAD Connecting to the GoPro Plus message displays. Soon, an "UPLOAD ERROR Set up the feature on the GoPro app" message displays. I press OK.

 

I press the camera icon in the GoPro app on my iPhone. I get the message "GoPro Wants to Join Wi-Fi Network GPxxxxxxxxxx?" While this message is displaying something appears in the background. It says "Make sure GPxxxxxxxxx" is on. At the bottom there are two options: Yes, Wireless is on and Get Support. As noted above, the network was on and connected when I started this. 

 

Now, it seems, I have four options

  • Yes, Wireless is on (from the background display)
  • Get Support (from the background display)
  • Cancel (from the "GoPro Wants to Join Wi-Fi Network GPxxxxxxxxxx?" dialog)
  • Join (from the "GoPro Wants to Join Wi-Fi Network GPxxxxxxxxxx?" dialog)

I select "Join". The "GoPro Wants to Join Wi-Fi Network GPxxxxxxxxxx?" dialog) disappears. The background display is still there (now in the foreground). I press "Yes, Wireless is on".

  • The GoPro App connects to my camera

BTW, I expect I have done this at least 10 times now. This is the first time I have seen these messages. 

 

Now, my GoPro is connected to my camera (based upon the fact that, from the GoPro app, I can see what my camera sees. I press the return arrow in the upper left hand corner. I see "Camera" page.

 

So now, my GoPro is connected to my camera ... please note that it was connected to my camera when I started this and I have no idea whether it really was disconnected and / or how it became disconnected. All that I know is that it was connected, then the GoPro app said it was not connected, and then, when I confirmed that the Wireless Network was on, the GoPro app is connected.

  • This does not necessarily mean that the GoPro app was not connected ... it could mean only that something internal to the GoPro app thought it was not connected

At any rate, I am connected.

 

I unplug my camera.  I am going to do this again. My camera reports that my battery is now 95% charged. I plug my camera into the charger. I wait. I get an "UPLOAD ERROR Set up the feature on the GoPro app" message displays.

 

This time I don't press OK (on the camera). I go to my GoPro app and press the Cloud icon. Auto Upload is On. I press "Wireless". I should be connected to my home network (it was just a moment ago when I connected for the umpteenth time). There is no indication that my Home network is connected. I press my home network. I get the message that I am connected and Auto Upload is on. I return to the "Home" page.

 

On the camera, I press OK (remember, as indicated above, I went to the GoPro app and connected to my Home network before pressing OK on the camera). So, on the camera, I press OK. Nothing looks promising, so I will repeat one more time.

 

I unplug the camera from the charger. The camera reports that the battery is 98% charged. I plug the camera into the charger. A charging indicator appears. The "STARTING UPLOAD Connecting to GoPro Plus" message appears. The "UPLOAD ERROR Set up this feature on the GoPro app" appears.

 

And, on and on and on it goes. Seems to me an endless loop.

 

On the camera, I press the Cloud icon. It now says my GoPro app is not connected. I go to the GoPro app. I press the Camera icon. I get the message "GoPro Wants to Join Wi-Fi Network GPxxxxxx?". I press "Join". I get a message "Camera Disconnected."

  • Isn't this fun?

I return to the "Camera" page. I press the camera icon again. This time I see what the camera sees. So, the camera must be connected.

 

Returning to the camera, it still says the GoPro App is not connected. I return to the camera's main (home) page. I swipe down and press "Connect". It says the GoPro app is connected. I scroll down. This time I am going to press "Manual Upload". The camera says STARTING UPLOAD  Connecting to GoPro Plus. The GoPro app just displayed a message WI-FIL CONNECTION LOST .... Make sure it's awake and WiFi is on. Then try reconnecting to your GoPro in your iPhone's Wi-Fi settings.

 

Isn't this a bit rediculous.

 

At any rate, I want to make this work so ... My requests

  • What am I doing wrong
  • If I am not doing anything wrong, (a) what is going on here (why is the Auto Uploading Your Footage to the Cloud With GoPro Plus not working), (b) why does the manual update not work and (c) what should I be doing, instead of the above, to get connected to GoPro Plus?

 Also, I should point out that I was once connected to GoPro Plus. The videos I took a week ago are uploaded. It is just that all videos since then will not upload.

Highlighted
Hiker
Posts: 7

Re: Cannot Upload to GoPro Plus

And, BTW, when I open Quik on my computer there is what looks like a busy icon in the upper right hand corner to the left of the Settings icon. This busy icon churns constantly.