Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Sightseer
Posts: 2

Can't update new Hero 8 Black

[ New ]

Ok, so I'm getting super frustrated with attempting to update this camera. Specifically, I want to use this camera with a livestream setup and purchased the media mod to use with it. When I first turned it on it told me it needed an update to use the mod. Not a big deal, I thought. Man was I wrong.

 

I installed the Quik software on my phone (Note 10+). The app seemed to connect via bluetooth to the GoPro8 fine. It asked if I wanted to update, I touched the update button and it just sat there, for probably 10 minutes showing a "reconnecting" screen. I did a factory reset on it (which is ridiculous, since this is a brand new device), same problem. I changed the wifi connection to 2.4 ghz. Still it got stuck on the "reconnecting" screen on the phone app. I formatted the SD card, still no luck. I have deleted and reconnected the camera to the phone app multiple times, all with the same result.

 

Note that I have not been able to, from the beginning, use the live view function of the app. I don't think the camera is connecting properly with my phone, but I have no way of dailing in what is the problem there. The phone thinks it has a good connection and my phone shows that I am connected via bluetooth. But when the phone tries to connect to the GoPro 8 via wifi it seems to just...fail. And I've tried both the 5 ghz and 2.4 ghz bands.

 

I thought I would just download the update from GoPro's website and do it manually through the SD card. When I filled out the form on GoPro's website, the download button would not generate properly and I could not download the update. I tried this in both a chrome browser (clearing my cache after it didn't work the first two times I tried it, still no luck) and then a firefox browser - same stupid issue: the download button blinks "download" for split second as the page loads and then says "generating" and will not work.

 

I downloaded the Quik for Desktop software, but apparently this software cannot actually update the newer GoPro cameras, including the GoPro 8 Black.

 

Any advice would be greatly appreciated. Heck, a simple link to the update file would probably help me. I don't need to use the GoPro app, I just need the media mod to work properly. 

Sightseer
Posts: 2

Re: Can't update new Hero 8 Black

[ New ]

Update: Well, my Firefox browser (after several refreshes of the page) finally yielded a download option for the update, so I was able to successfully update my GoPro Hero 8 Black. It still will not connect properly with my phone (I can't preview the video live feed on my phone), so if anyone has any advice about connecting a GoPro Hero 8 with a Note 10+, I would appreciate it. But the update issue seems to have been settled.

GoPro
Posts: 27,117

Re: Can't update new Hero 8 Black

[ New ]

Hi @redshirtron

 

Thanks for the update. @redshirtron

Do you have version 8.1 installed on your phone?

What resolution are you setting the camera in?

 

If you haven't yet, try resetting the connection.

Delete the camera from your camera history.

Then delete the GoPro camera under the Bluetooth and Wi-Fi entries in your mobile device’s settings before attempting to re-pair to your GoPro.

 

Thanks!

Ej