Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see if it is on our Update page.
Cameras
Reply
Tourist
Posts: 5

Camera is not working after filming underwater

[ New ]

Hello,

 

I've opened a case at the begining of August and I did not get any response. 08116688.

 

My camera (Hero 8 Black) did not start after I took some videos in the Mediterranean Sea. I thought the battery ran out, and when opened the lid to change it, I saw that the interior or the camera and the battery were wet. Camera serial number: 31350327113.

Now:

- the battery can't be charged.

- the camera doesn't start (with spare original battery).

The camera is still in the waranty period and I am also a subscriber of GoPro Plus.

 

I need a response from your support team.

 

Thank you,

Adrian

GoPro Community Manager
Posts: 7,802

Re: Camera is not working after filming underwater

[ New ]

@adrianstroe - I checked the status of your case and our team did try to reach you a couple of times, but it appears that the phone number you submitted may have been entered incorrectly. If you start a new case at https://gopro.com/help/ContactUs, we'll try to see what we can do to help. Thanks.

Tourist
Posts: 5

Re: Camera is not working after filming underwater

[ New ]

Hello, Jeff,

 

I haven't been contacted by your suppport colleagues. Your reply here is the single form of response to my case, from August until now.

 

My phone number was correctly submitted then, in August, and in the cases opened after. The phone prefix for Romania is +40 or 0040. If you dial +40724277316 or 0040724277316, my phone will ring. I have the same number. If somehow my phone has no network coverage when your colleagues try to reach me, not very likely, notify me somehow (by email, for example, at adrian.stroe@gmail.com).

 

I've opened two new cases, mentioning the original case number, 08116688. I don't know if it was right or wrong to mention the old case number, but my logic was to present the proof that I had been trying to contact you guys for almost 4 months ago.

 

I can't open a new case, because when I click on "request a call" or "start chat" I get an error: Invalid Captcha. I tried it using two different browsers (Chrome and Firefox) from two different computers with diferrent operating systems (Ubuntu 20.04 and Catalina MacOS). I can't see any Captcha on your page.

 

I don't want to hurt anybody's feelings, but considering all these facts, I'm quite dissapointed by the your Customer Support Service.

 

Hope to sort this one out. Thanks!

captcha.png
GoPro
Posts: 30,857

Re: Camera is not working after filming underwater

[ New ]

Hello @adrianstroe

 

Sorry for any trouble caused.

Would you mind logging another request?

Do not reference the previous case number.

 

Should you encounter any issue scheduling a callback or a live chat, please ensure that you are not blocking cookies and have your pop-up blocker disabled.
You may also try a different browser or go on incognito mode.

 

Let us know how it goes.

 

Thanks!

Ej

 

Tourist
Posts: 5

Re: Camera is not working after filming underwater

[ New ]

Hello again,

 

I made sure I have agreed to your cookie policy and used the browser's incognito mode.

I've tried to submit a new case yesterday afternoon, this morning and five minutes ago. Your agents are busy helping other customers, as you can see in the screenshot I have attached.

 

My feeling now is that your support team will not contact me anytime soon. As a fan of your brand, as a customer and as a GoPro Plus paying subscriber, I am deeply dissapointed.

 

You have a week to contact me (phone/email) regarding my broken camera. If this doesn't happen, I will file a consumer complaint on the Fedaral Trade Comission's website.

 

For one last time, the details of my issue bellow:

-------------------------

Hello,

 

I've opened a case at the begining of August 2020 and I did not get any response. 08116688.

 

My camera (Hero 8 Black) did not start after I took some videos in the Mediterranean Sea. The camera was attached on a head-support. I took it to maximum 2 m depth. I thought the battery ran out, but when I opened the lid to change it (I have an original spare battery), I saw that the interior of the camera and the battery were wet. The camera was also covered in a silicone/rubber protective cover and also had on a plastic display cover. Camera serial number: ***.


Now:
- the original battery can't be charged (I have an original GoPro dual charger) and obviously, the camera can't start using it;
- when using the spare original battery, the camera starts but the screen is black and I can't perform any action.

The camera is still in the warranty period and I am also a subscriber of GoPro Plus.
I need a response from your support team.


If you have trouble reaching me by phone, my number being +40 *** or 00***, you can write me an email, at adrian.stroe@gmail.com, or give me a phone number which I can call. Thank you!

 

Sincerely,
Adrian

------------------------

no-agents.png
GoPro
Posts: 30,857

Re: Camera is not working after filming underwater

[ New ]

Hi @adrianstroe

 

Sorry for any trouble caused.

Can you please log a callback request on a new case?

Please take note of the case number so we can follow up with the team.

 

Thanks!

Ej

Tourist
Posts: 5

Re: Camera is not working after filming underwater

[ New ]

Hi, EJ,

 

I cannot open a new case and request a call because I keep getting the "Invalid captcha" error. If I want to "start a chat", I won't work either, because "Sorry, all agents are helping other customers right now. Please try again later."

 

If you need a case number, you can use the one back in August, 08116688. Your colleagues didn't call me back because, they say, I wrote the wrong phone number.

 

Now you a have a case number, you have my phone number, you have my email... I totally understand you have to follow some protocols to call somebody back, but this is embarrassing... Anyway... 

 

Adrian

 

GoPro
Posts: 30,857

Re: Camera is not working after filming underwater

[ New ]

Hi @adrianstroe

 

We'll have this followed up with the team.

Your case has been assigned back to the queue.

Support will be reaching out to you soon.

 

Thanks!

Ej

 

 

Tourist
Posts: 5

Re: Camera is not working after filming underwater

[ New ]

Hi,

 

I finally managed to get in touch via chat with one of your colleagues from support.

He was very helpful and after a few minutes we got the issue sorted.

On Monday UPS came and took my camera to your offices in the Netherlands.

 

Adrian