Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
Posts: 4

Bricked Hero 5 Session

[ New ]



seems my Session 5 got bricked when I tried updating it to the latest firmware version. Currently the LED blinks red on the front side. LCD Screen is off and no duration or combination of button presses are doing something. Re-Inserting sd cards does not help either.


So I tried to update the firmware via the app and it seemed fine at first but got stuck at "1/2". After that I did a manual update and put the folder on my sd card, put it in the gopro and it got stuck at "2/2". Tried it again, but same result. Even different sd cards. I found out that the my sd cards, all SanDisk Ultra, caused problems for other people too. I have previously recorded with no problems to a SanDisk Ultra 64GB. Sometimes during all those attempts the LCD screen started to stay off. I borrowed a Toshiba Exceria 128GB but nothing happens, still only the red front led blinking all this time.


What should I do now?

Why are SanDisk Ultras not working for firmware updates? I understand that sd cards with not enough speed could cause problems when recording (which I had not), but I don't get it why it's causing the update to fail.